Jump to content
JWTalk - Jehovah's Witnesses Online Community

2001 pt cruiser has an overheating problem


We lock topics that are over 365 days old, and the last reply made in this topic was 2913 days ago. If you want to discuss this subject, we prefer that you start a new topic.

Recommended Posts

Friend of our came from Sarnia to stay with us for the convention. I am worried about her car. She had the engine flushed and the fluid was supposedly replaced. She got to our place and the reservoir for the rad was empty. I am worried that 

 

1 the people didn't fill it up properly or 

 

2 the engine may have a head gasket problem and is sending the fluid out the tailpipe. If that is the case this will be an expensive repair. I would rather have it be a leak in the cooling system.

 

Anyone else have a cooling problem with theirs? 

Link to comment
Share on other sites

Ya I took it to my mechanic and he showed me a couple problems. Its a wonder she hasn't cracked the head or the block on the thing. I will get it fixed up for her. There is also a problem in the rear suspension. Its banging like a sledge hammer when it hits the smallest hole or bump. I want to make it safe for her. She thinks she will have to pay for it. Nope I will take care of it.

Link to comment
Share on other sites

Did you get the overheating problem fixed?

 

The PT is basically the sane as a Dodge Neon. There are some models that have the plug on the electric fan that cools the radiator resting against one of the A/C lines (I think it is an A/C line) and it rubs it until, after time, it no longer makes good contact and the fan does not always run.

 

You may have to slightly bend the lines, they are metal lines, to create a gap for the plug so it no longer rubs and try to make sure the plug is in tight.

Link to comment
Share on other sites

My Mechanic will give me an estimate today he can't do the work till Monday tho. I don't mind it give us a chance to make her relax with booze LOL.

 

He said that the housing on the top of the engine that the rad hose goes in is leaking. POssible break in it. And there is a tube that runs from the bottom of the engine. It returns the water to the bottom of the rad. It is so rotted that its a wonder it can take pressure from the system. So he thinks that is where the major problem is. 

 

I checked the fan its working fine. I was worried she had a blown head gasket but that doesn't appear to be the problem now. 

Link to comment
Share on other sites

About JWTalk.net - Jehovah's Witnesses Online Community

Since 2006, JWTalk has proved to be a well-moderated online community for real Jehovah's Witnesses on the web. However, our community is not an official website of Jehovah's Witnesses. It is not endorsed, sponsored, or maintained by any legal entity used by Jehovah's Witnesses. We are a pro-JW community maintained by brothers and sisters around the world. We expect all community members to be active publishers in their congregations, therefore, please do not apply for membership if you are not currently one of Jehovah's Witnesses.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

JWTalk 22.5.22 (changelog)