Jump to content
JWTalk - Jehovah's Witnesses Online Community

WT Lib not updating.

Recommended Posts

I know there are several posts on this but they are 3 years old.  I have 2 laptops.  One of them updates, the other does not.  They are both windows 10 but with different processors.  I have tried uninstalling, rebooting and reinstalling several times.  I have tried automatic updates w/o success.  I have tried to create and apply update package, again w/o success.  If anyone has any advice it would be most appreciated.  Thanks in advance

Link to comment
Share on other sites

One of my computers also had this problem. A laptop that is very slow . The laptop had not processed the last 2-3 updates. In the summer we spent 3 days vacation in a hotel with very fast internet. I deleted, reinstalled and updated WTLib. That was about 4.5 GB. Everything is going well now. I think a bug crept in with an earlier update.

Link to comment
Share on other sites

I had the same problem and it gave me a headache. I even called the Branch. 😂 They said it was on the worldwide list of issues. But  I solved the Problem.

When you want to run the update manually it shows a box in which you can choose for more details. So I clicked on it and it showed the path to the update package. Which I found strange because it wasn't were I had saved the update. After going there, there was a txt file from a previous attempt, which I openened. This is what it said:


16-10-2020 16-25-44-25M: Platform 2.10, Build 7632
16-10-2020 16-25-44-25M: Started updater thread.
16-10-2020 16-25-44-25M: Extracting the update package: C:\Users\jgmol\AppData\Local\Watchtower\WTLibrary\O\WTO\Updates\lyu_O.updatepkg
16-10-2020 16-26-30-26M: Extracting : C:\Users\jgmol\AppData\Local\Temp\WTLibrary.O.WTO.2008.BASE.UPDATEPKG
16-10-2020 16-27-00-27M: wtlibrary.exe current revision: 7632
16-10-2020 16-27-00-27M: Found wtlibrary.exe in update package:  Revision: 7632
16-10-2020 16-27-00-27M: wtlibrary.exe will not be updated
16-10-2020 16-27-10-27M: A file exception occurred for file C:\Program Files (x86)\Watchtower\Watchtower Library\O\rs_data_indexing\PUBS\LF_O\LF_O.MMDB
The disk is full.

16-10-2020 16-27-10-27M: Update Failed
16-10-2020 16-27-10-27M: Deleting C:\Program Files (x86)\Watchtower\Watchtower Library\O\system
16-10-2020 16-27-10-27M: Deleted
16-10-2020 16-27-10-27M: Deleting C:\Program Files (x86)\Watchtower\Watchtower Library\O\rs_data_indexing
16-10-2020 16-27-10-27M: Deleted
16-10-2020 16-27-10-27M: Destroying updater dialog
16-10-2020 16-27-14-27M: Destroying library update manager

 Note that it says: The disk is full.

So I removed some Onedrive files to gain more diskspace and tried it again. It updated without problems. 


So it may be useful to go to the update location and see if an error is mentioned in a txt file:


You may not be able to see AppData since it is hidden by default. To make it visible go to Explorer and select the View Tab. Select Hidden Items on the right. (If that's how it is mentioned. I use the Dutch version so I am not used to the English names). Follow the path to find the update folder. jgmol has to be replaced by your own user name of course. 


I hope this is of help to some of you.

Edited by molnarj
Link to comment
Share on other sites

I would first check if the disk is full or almost full. This is the most common reason for this issue.


If that is not the problem, I would uninstall Watchtower Library but, instead of reinstalling from the DVDROM, download the whole program as an ISO image from the official site:


(click on Download, choose the language, then click on the ISO button. It's a big download!)


Once the file is downloaded, in Windows 10 you just need to right-click on it and select mount, and it will appear as if you had inserted the Watchtower Library DVD on the drive. Just install normally from there. Once installed you can Eject that "virtual" DVDROM and delete the file. Now it should update correctly.

Link to comment
Share on other sites

Join the conversation with your brothers and sisters!

You can post now, and then we will take you to the membership application. If you are already a member, sign in now to post with your existing account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

About JWTalk.net - Jehovah's Witnesses Online Community

Since 2006, JWTalk has proved to be a well-moderated online community for real Jehovah's Witnesses on the web. However, our community is not an official website of Jehovah's Witnesses. It is not endorsed, sponsored, or maintained by any legal entity used by Jehovah's Witnesses. We are a pro-JW community maintained by brothers and sisters around the world. We expect all community members to be active publishers in their congregations, therefore, please do not apply for membership if you are not currently one of Jehovah's Witnesses.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

JWTalk 23.8.11 (changelog)