Jump to content
JWTalk - Jehovah's Witnesses Online Community

Does Anyone else have trouble Installing Watchtower Library 2013?


We lock topics that are over 365 days old, and the last reply made in this topic was 3051 days ago. If you want to discuss this subject, we prefer that you start a new topic.

Recommended Posts

Hey everyone!  I hope you have all had great success in downloading the files from the new Watchtower Library 2013 CD onto your computer's hard drive, but a small part of me is hoping there are a few of you going what I am going through and might be able to help.  My CD won't download onto my Toshiba Windows 8 laptop (it's relatively new, 6 months old or so).  It starts to install and gets to 15% and the CD stops spinning and then I get a box that says "Are you sure you want to cancel install to hard drive?" If I click "no" then it constantly loops between stopping at 15% and the box wanting to know if I want to cancel the install".  I kill the process in task manager.  I had no trouble installing on my Windows XP "ancient of days" computer.  The funny thing is I can install the Watchtower Library 2012 on the Windows 8 and it installs to the hard disk just fine!  Does anyone out there have any info that might help me with this problem.  I feel like I've tried everything (booting to safe mode, scanning system files for problems and so on and so forth).  The file in the dialog box that tells you the percentage of the installation is "WTE.LIDX" - not sure if that's the file it is hanging up on or what.  Perhaps they've changed something in the registry between Library 2012 and 2013.  Any help would be greatly appreciated! :D

Link to comment
Share on other sites

Christopher, do you mean you don't get the WT Library in CD ROM in the UK?? I would move to one of the colonies if I were you! :)

 

Yes, we do, Musky.  Just months after the USA as with all things.  We have no meeting now for 2 weeks because of our one day Circuit Assembly (sorry SAD), so it will be almost out-of-date before we get it.  I am fortunate to have iSilo and kind brothers in the colonies who make it available this way.

 

When they build the bridge, I may come visit you one day.

Link to comment
Share on other sites

1st of all. Uninstall all previous WT lib.

2nd. Do the free update to windows 8.1  -

you do it through the windows store tile ( in tile mode ). You have to be signed into your live account. 

If the win 8.1 update doesn't show up then you need an update. "Windows8-RT-KB2871389-x64.msu" for 64 bit system and similar but for 32 bit system -

depends which you have. Most newer computers run 64 bit operating system ( 4 Gb + Ram ).

Once done updating to win 8.1 & restarting

then clean your system of trash, and unwanted files.

(Next Personally I would add Free startmenu from Iobit )

Switch to desktop ( tile )

 

Run a defrag program ( I use free versions -Auslogic or WiseCare 360 Free ).

Try making a folder on a 2nd partition called 2013 WTlib -if you have or on main partition if you must. 

Copy complete WT lib 2013 to folder that you just made on disk.

Open folder and  right click on setup and run as administrator.  Make sure you choose setup on computer and install files on computer ( not mobile ).

Should work.

 

Sometimes you have to temporarily disable antivirus

Edited by pnutts
Link to comment
Share on other sites

I'm having difficulties loading it into my IMac ... Any help would be appreciated.

Sent from my iPad using Tapatalk

 

If you are trying to install it from the CD directly to a MAC, it will not work. It is designed to run on a Windows-based computer. But, using the method and free download on this site, will enable you to install the Library on your MAC:

 

http://watchtowerlibraryformac.info/en/pages/1-home/content

Link to comment
Share on other sites

Hi Peter!  Thanks for replying to my post.  Unfortunately I had already done everything you had talked about while trying to install the WTLibrary to my hard drive, except for creating a folder prior to the installation.  I just tried that and that installation failed to.  No matter what I do, the installation always stops dead at 15% - disk stops spinning.  It only installs 5 small files and then 267KB of the WTE.LIB file.  I've tried two other new disks and they do the same exact thing, and like I said the 2012 WTLibrary installs just fine.  I updated to Windows 8.1 when the update first came out weeks ago so I know that isn't the problem and I also shut down any programs I feel would cause interference as well as tried installing it in safe mode.  I always disable my anti-virus whenever I install a new program too.  The only thing I didn't try that you suggested is making the 2013 WTlib folder on a 2nd partition, I did it on my main partition (because I have no experience with setting up partitions).  Any other suggestions to get it to install on my hard drive would be greatly appreciated!!! :uhhuh:  

Link to comment
Share on other sites

I'm on my phone so I haven't read all posts, but instead of running the setup file on the CD, did you try just copying the contents of the CD to a folder on your hard drive? Then, once the files are copied to the folder, try running the setup file from there, within the folder?

 

EDIT: @Brigette, I just sent you a PM.

Edited by Musky
Link to comment
Share on other sites

Hi Musky,  Thanks for the suggeston, I will definitely try that!  This is the third C.D. that has done this to me.  There is one other person I know of in our congregation having the same problem but I don't think it's with a Window 8 computer.  It could be that we got a batch of faulty C.D.'s as Jonathan77 suggested because I think the society sends them out to be made now but since the exact same thing happens every time, I can't help but wonder if it's my computer.  I will try your suggestion Musky and reply back so you know whether it worked or not!  Thanks again!

Link to comment
Share on other sites

Just to let everyone know, I sure appreciate all the help I got with this problem but it's finally solved!  A brother very graciously sent me a .zip file of the CD and I was able to download, open and extract it just fine and now it's installed on my hard drive!  Apparently there must of been a file on the CD my computer didn't want to read but accepted it when it was already on it thru the download (or something like that!).  Anyways, problem solved - now on to the next days anxieties!! haha!

Link to comment
Share on other sites

Thanks for the advice Jonathan, but my computer is brand new.  This is only the 2nd or 3rd CD I've ever put in it.  The other 2 read the CD just fine and loaded the program.  This particular Watchtower CD is the only one I've ever had a probelm with, like I said before - when I couldn't download the info to my hard drive, I tried loading the 2012 Watchtower Library to my hard drive and it did it! Could be a change in a registry key my computer doesn't know what to do with or a faulty CD - I'll probably never know!  Sure do appreciate everyone's help with this though, especially Musky!!!

Link to comment
Share on other sites

About JWTalk.net - Jehovah's Witnesses Online Community

Since 2006, JWTalk has proved to be a well-moderated online community for real Jehovah's Witnesses on the web. However, our community is not an official website of Jehovah's Witnesses. It is not endorsed, sponsored, or maintained by any legal entity used by Jehovah's Witnesses. We are a pro-JW community maintained by brothers and sisters around the world. We expect all community members to be active publishers in their congregations, therefore, please do not apply for membership if you are not currently one of Jehovah's Witnesses.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

JWTalk 22.5.22 (changelog)